
Pleo Booklet: Instructor

Introduction to Pleo
What is Pleo?
Pleo is a robotic dinosaur created by UGobe Life 
Forms. Pleo can interact with people and objects because she has her own senses and 
behaviors (such as eating, sleeping, and playing). Pleo can also express herself through 
noise and gestures. Not only does Pleo have behaviors, but each Pleo also has her own 
unique personality. This personality is developed when Pleo is !rst turned on and 
helps de!ne how Pleo interacts with people later on in her life. Most importantly to us, 
however, Pleo is programmable! This means that anyone can learn how to program not 
only different personalities but also speci!c behaviors for a Pleo to perform. 

Purpose and Motivation for the Workshop
Our goal for this workshop is to introduce students to computing in an engaging way. 
We plan to do this by allowing them to explore computer programming by teaching a 
robotic dinosaur tricks.  Currently, the environment we are using for the Pleo only lets 
us introduce simple sequential programming and event driven programming.  We also 
plan to introduce the students to research on Arti!cial Intelligence by demonstrating 
the Pleo's built-in behaviors.

Workshop Cost Analysis
This workshop is designed to have one station per girl. One station has the following 
required and recommended items:

Quantity Item – Required Price
1 Computer – DELL OptiPlex 360 Minitower $597
1 Pleo $349
1 Extra Pleo Battery $49
1 SD Card – 2GB $7
1 SD Card Reader (if the computer does not have a built-in SD Card 

Reader)
$15

1 Browser (Internet Explorer or Mozilla Firefox) FREE
1 MySkit Environment FREE
1 Flash 10 or higher FREE

TOTAL $1,017
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Quantity Item – Recommended Price
1 Microphone $15
1 Headphones $10

TOTAL $25

Pleo Hardware
Pleo has certain sensors or "senses" which allow her to interact with the world. These 
sensors are: 
• Infrared transmitters and receivers on her nose allow Pleo to 

identify and interact with other Pleos.

• Infrared interrupter allows Pleo to detect when something 
has been placed in her mouth.

• Microphones on the left and right sides of her head which 
allow her to detect noise.

• A color camera on her nose which allows Pleo to detect light, 
color, and motion. Pleo can also tell when something is 
blocking her path or when there is no more table or other high 
surface to walk on ahead of her. (note: she cannot tell when 
there is not a surface to her side or behind herself and 
therefore still needs to be watched closely in order to avoid 
injury).

• Touch Sensors on her 
chin, head, shoulder, 
lower back, and legs. 
Each touch sensor 
allows Pleo to feel when 
she is being tickled, 
handled, and so on. 
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• Speakers in her mouth 
and right above her tail 
which allow Pleo to 
communicate with 
noise. 

• Tilt and Shake sensors which allow Pleo to 
know her orientation. 

• Ground Sensors which allow Pleo to know if 
she is on a solid surface or if she has been 
picked up. 

• Force feedback sensors on her legs, neck, tail, and torso motors allow Pleo to know 
when she is being handled roughly, which then affects her personality and mood. If 
Pleo is being handled too roughly, she will shut down in order to avoid internal 
damage.

In her belly, Pleo has a battery which can be charged outside of Pleo's body and then 
placed inside her for use, an SD card slot (which is discussed in more detail below), a 
power switch, a "Pleo button" and a mini USB port.  
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The "Pleo button" has two functions: 
• Holding the Pleo button for ten seconds puts her into the packaging position. Be 

prepared to turn her off quickly; she will only be in this position for a couple second 
before she resumes wiggling.

• Pressing it once will mute the Pleo, twice will make the volume soft, and three times 
will put it back into normal volume mode.

The mini USB port allows you to plug Pleo into the USB port of a computer. There is a 
mini USB to standard USB cable that comes included with Pleo.

SD Card
The SD card slot in Pleo's belly is what will allow the students to play their own Pleo 
programs. Each student or group of students will be given an SD card and SD card 
reader along with their computer and Pleo. Each SD card will also come with a default 
trick which we will provide. The students will then be able to create their own 
programs using their computers and save them onto the SD 
card with their SD card readers. (More detailed descriptions 
will be provided in the workshop documentation). Once the 
SD cards have been loaded, all the students will have to do is 
place them in Pleo and turn her on. Each activity will have 
been set to a touch sensor (during the saving process) which 
must only be lightly pressed to activate. 

Pleo’s Personality
Pleo has four different moods: happy and curious, playful and lively, scared and 
surprised, and sad and vexed. Pleo's likelihood to be in any one personality depends 
both on her own personality and how she's being treated. A Pleo who is being hung 
by her tail might easily become sad and vexed, but a Pleo being fed and played with is 
much more likely to feel playful and lively. 

Computer Setup
Downloading the Files
All the !les you need for this workshop can be found in ICE’s website <http://
coweb.cc.gatech.edu/ice-gt>. On the main page select “Resources for Teachers” and 
then “Pleo Resources.” Here you will !nd a Pleo_Files.zip.  This !le contains the 
following folders and !les:
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• Instructor_Resources Folder
• Completed_Skits Folder

• Beg Pleo.pleo
• Bow Pleo.pleo
• Sit Pleo.pleo
• Speak Pleo.pleo
• Wag Tail Pleo.pleo

• MySkit Folder
• MySkit.exe

• Booklet - Pleo Intro.pdf
• Booklet - Workshop.pdf
• Install_Flash_Player.exe
• Installing Flash - Read Me.pdf
• Installing MySkit - Read Me.pdf
• Instructor_Presentation.pdf
• Instructor_Presentation.ppt
• Instructor_Presentation_Notes.pdf
• MySkit-v1.3-Installer.exe

• Sample_Skits Folder
• Sample_Program.pleo

• Website_Files Folder
• Pleo Instructions.html (may either have an Internet Explorer icon or a Firefox icon)

The Instructor_Resources folder has all of the materials you need to setup the 
computers and run the workshop.  Inside the Instructor_Resources folder, you will !nd 
the Completed_Skits folder which contains a completed version of the skits the 
students will be working on. The MySkit folder contains the MySkit.exe !le that can be 
used to transfer MySkit to your computer without having to install it.  For instructions 
on how to do this, see the Programming Environment Introduction of this document. 
Inside the Instructor_Resources you will also !nd several !les; you will !nd the two 
booklets we have created for you, the installer for Adobe Flash 10, which you will need 
to be able to play the videos that are on the student website we have created for you.
We have also included the PowerPoint point presentation you can use for the lecture 
part of the workshop. This PowerPoint presentation has notes on suggested topics to 
address during the lecture.  You will also !nd the MySkit installer which will allow you 
to install MySkit.  Finally, you will !nd two Read Me !les; these are provided for you in 
case you need a school administrator to install Flash and/or MySkit.

You will also !nd a Sample_Skits folder This is where the students will be saving their 
skits.  This folder has a Sample_Program.pleo, which is a simple MySkit program.
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You will also see the Website_Files folder.  This folder contains all the !les that make up 
the website.  And !nally you will see the Pleo Instructions.html !le which is the !le that 
will allow you and the students to view the website.

Setting up the folders
When you download the Pleo_Files.zip !le, depending on the browser you are using, 
one of two things may happen; the !les in the zip will be placed in the directory you 
speci!ed or the !les will be placed inside another folder called Pleo_Files in the 
directory you speci!ed.
We recommend that you place the Sample_Skits folder, the Website_Files folder, the 
Pleo Instructions.html !le and the shortcut for MySkit on the desktop for easy access. 
The Instructor_Resources folder can be placed on the desktop as well.

Setting up the website
For the website to work properly both the Website_Files folder and the Pleo 
Instructions.html !le must be in the same place.  We recommend you place both on 
the desktop, but if you are not able to place the !les on the computer’s desktop, you 
do need to place both, the !le and the folder, in the same folder, otherwise when you 
double click on the Pleo Instructions.html !le you will get an error and you will not be 
able to see or use the website.

Programming Environment
Introduction  
This guide should help you to get started using MySkit. For a complete reference of all 
of MySkit’s features, please visit the software creator’s website <http://
www.dogsbodynet.com/MySkit/index.html>. This tool allows you to create your own 
actions for Pleo and even add sound to them. 
  
Installation
System Requirements:  
• Windows 98 or newer  
• 800 MHz+ processor 
• 3D graphics card 
• At least 220 MB of hard drive space  
• SD Card reader  (built-in or external) 
• SD Card with at least 8 MB
• Sound card (optional, but highly recommended)
• Microphone (optional)
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To begin, extract the !les from “Pleo Files.zip” onto the desktop.  You will need to install 
MySkit if it is not already installed on the computers the students will be using. To 
install MySkit, please run the "MySkit_Installer.exe" that came in the zip !le in a folder 
named "Instructor_Resources" and follow the prompts it presents to you. If this does 
not work, please go to <http://www.dogsbodynet.com/MySkit/
index.html> and follow the website's instructions for downloading the 
MySkit installer. Now, run this installer and follow the prompts that are 
presented. Once MySkit has been installed, you should have a shortcut 
to the program on your desktop.
  
Next, you should be sure that all the necessary !les have been saved or manually 
placed onto the desktop. This should include "Sample_Skits," “Website_Files,” and the 
!le “Pleo Instructions.html.” 

Alternative installation method
If you do not have administrative access to the computer you are using or for whatever 
reason cannot install MySkit onto the computer, there is an alternative method of 
getting the program working on your computer. Inside of the “Instructor_Resources” 
folder, there is a MySkit folder that has a MySkit.exe !le in it. This !le is all you need to 
run MySkit. Here are the steps you must take in order to use this !le:

1. Click on the desktop and select “New” and then from the window that appears 
select “Shortcut.”

2. A window will launch which will step you through the process of creating the 
shortcut.

3. Navigate to the “Instructor_Resources” folder.
4. Select the “MySkit” folder.
5. Select the “MySkit.exe” !le.
6. Double click on MySkit and it should load.

Keep in mind that installing MySkit in this way is not a full installation. Some small 
differences in program performance will occur. First, MySkit !les will not have the usual 
MySkit icons. Second, double clicking MySkit !les will not automatically open the 
program. In order to use these !les, you will need to open MySkit !rst and then select 
“File” and then “Open...” and navigate to the !le in question. 
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Editing Pleo’s Motion
When you !rst open the program, you should see something similar to 
the picture here:

Each skit is composed of the two main windows you see: the Motion Editor 
and the Wave Editor.  Note: if you do not see the Motion Editor and Wave 
Editor windows just press the "New" button on the upper toolbar and 
they should appear. You probably want to go ahead and save your skit by 
going to File->Save As... and putting your new skit into the "Sample_Skits" 
folder.  

Pleo’s motion is controlled by creating a number of keyframes that indicate what pose 
Pleo should be in at a speci!c time. A keyframe consists of setting the position value 
for each of Pleo’s servo motors. The timeline across the top of the Motion Editor is used 
to specify the timing of each pose, which will determine how fast Pleo will move (see 
!gure below).  You can think of the timeline as working similarly to the timelines in 
programs such as Garageband, iMovie, or Windows movie maker. Time begins on the 
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left and moves to the right. The more space a move takes the slower it will be and 
similarly the less space it takes the faster it will be. You can create a keyframe using 
three major methods:  

• Click on one of the black lines controlling Pleo’s motor at the desired time. You can 
drag the line up and down to change the value of Pleo's motor at that particular 
time.

• Select a time, then manually input a value for the motor. After you have entered the 
desired value, press enter and you will see how the line is affected. 
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• Select a time, then modify the pose of 
the 3D model in the PLEO Window. This 
will automatically insert the correct 
values for the affected motors and 
update the motor lines appropriately.

The PLEO Window is a very useful way to keep track of what you are doing and make 
adjustments in your program. You can access it by going to View->PLEO Window. By 
creating a sequence of these keyframes, you can get Pleo to perform almost any 
action. The only limits are the range and speed of the servo motors. Luckily, MySkit will 
indicate if you are exceeding Pleo’s limits. If one of the lines controlling Pleo’s motors is 
red, then this means the motor is moving too fast. If the line is yellow, this a warning 
that the motor has reached its maximum speed. You can either !x this yourself or go to 
Motion->Fix Fast Servers or by manually adjusting the lines so that their slope is not so 
drastic. As you would probably suspect, MySkit also allows you to copy, cut, and paste 
your keyframes. Once you have 
created your new motion for Pleo, 
you are ready to add sound to your 
action.  

Editing Pleo’s Sound  
FIrst, If you do not already see the Wave Editor window, please click on the 
"Sound's" button in the toolbar at the top of the screen. You can see that 

the Wave editor is very similar to the 
Motion Editor. The keyframes that 
you established in the Motion Editor 
will carry over to the Wave Editor so 
that you can match up your sounds 
to Pleo’s actions. There are two ways 
of adding sound to your Pleo’s 
action:  

• Select a time, then go to Sound-
>Insert Sound… to select a .wav !le 
from your local hard drive  
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• Select a time, then use the Record and Stop buttons to record your own sound 
 
Loading the Action into the Pleo
Now that you’ve created your new action for the Pleo and added sound to 
it, you’re ready to load it onto the Pleo. First, make sure you have saved your 

new skit. Next, you will need to plug your SD card into the reader on your computer or 
your external card reader. You need to go to File->Setup Flash Drive and specify which 
drive letter corresponds to your card reader.

Now, you just need to click on the Write button located on the toolbar near the top of 
the screen. This will bring up a selection screen where you should select the 

"Sample_Skits" folder. 
After clicking OK, you 
will normally be 
presented with a screen 
that will allow you to 
select which sensor you 
want to activate your 
skit. You do this by 
simply dragging your 
action onto the 
appropriate sensor. 

Note: if the selected 
folder only has one skit 
in it, then MySkit will 
automatically assign 
this skit to the “Play on 
Startup” trigger. You 
must have more than 
one skit in the folder in 
order to assign each of 
them to a trigger. 

Your SD card should now be loaded with your new skit. Remove the SD card from the 
computer, plug it into Pleo, and turn Pleo on to test your new action.
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